博客
关于我
强烈建议你试试无所不能的chatGPT,快点击我
Super Jumping! Jumping! Jumping!
阅读量:7044 次
发布时间:2019-06-28

本文共 2001 字,大约阅读时间需要 6 分钟。

Problem Description

Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.
The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.
Your task is to output the maximum value according to the given chessmen list.

Input

Input contains multiple test cases. Each test case is described in a line as follow:
N value_1 value_2 …value_N
It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.
A test case starting with 0 terminates the input and this test case is not to be processed.

Output

For each case, print the maximum according to rules, and one line one case.

Sample Input

3 1 3 24 1 2 3 44 3 3 2 10

Sample Output

4103

Author

lcy
 
 
 
 
 
 
 
 
 
 
 
 

#include <iostream>

#include<algorithm>
using namespace std;
int a[1000],b[1000];
int main()
{int i,n,j;

    while(cin>>n&&n!=0)

{
        int s=0;
   
    for(i=0;i<n;i++)
        cin>>a[i];
    for(i=0;i<n;i++)
    {b[i]=a[i];
        for(j=0;j<i;j++)
        if(a[i]>a[j]&&b[i]<b[j]+a[i])
        { b[i]=b[j]+a[i];
        s=b[0];}}
      for(i=0;i<n;i++)
          if(b[i]>s)
              s=b[i];
          cout<<s<<endl;

}
return 0;
}

转载于:https://www.cnblogs.com/lengxia/p/4387864.html

你可能感兴趣的文章
php如何妩媚地生成执行的sql语句
查看>>
搜索引擎收录提交入口
查看>>
MongoDB简单实践:Only CRUD
查看>>
C语言杂谈——预处理程序
查看>>
如何从TFS中删除团队项目
查看>>
C++中的指针与引用
查看>>
Java取得操作系统的临时目录
查看>>
Visual Studio 2017 15.5.0 正式发布 正式版下载
查看>>
2.2 Consumer API官网剖析(博主推荐)
查看>>
[转]js日期时间函数(经典+完善+实用)
查看>>
iBATIS In Action:iBATIS的安装和配置
查看>>
endl用法
查看>>
关于Java基本数据类型
查看>>
GUID生成方式
查看>>
性能测试学习之三—— PV->TPS转换模型&TPS波动模型
查看>>
HDU 4028 The time of a day STL 模拟题
查看>>
Visual Studio 2008中 显示解决方案管理器中的解决方案节点,VS 2010 高级专业版 序列号...
查看>>
SharePoint Framework 构建你的第一个web部件(一)
查看>>
系统设计——权限系统
查看>>
SQL Server-流程控制 6,WaitFor 语句
查看>>